MySql.Data.Entity version compatible with MySql 5.6

Question:

Which versions of:

  • MySql.Data
  • MySql.Data.Entity
  • EF

Compatible with MySql version 5.6?

Answer:

I found the following table in the MySQL documentation . It shows which version of MySQL for Visual Studio is needed according to the server, Connector and Visual Studio version:

 MySQL for Visual Studio | Connector/Net | Visual Studio          | MySQL Server            | Observações                         
-------------------------|---------------|------------------------|-------------------------|-------------------------------------
 1.2                     | 6.9,6.8       | 2008, 2010, 2012, 2013 | 5.7, 5.6, 5.5, 5.1, 5.0 | Requer algumas funções do C/Net 6.9 
 1.1                     | 6.8           | 2008, 2010, 2012, 2013 | 5.7, 5.6, 5.5, 5.1, 5.0 |                                     
 1.0                     | 6.7           | 2008, 2010, 2012       | 5.7, 5.6, 5.5, 5.1, 5.0 |                                     
Scroll to Top
AllEscort