Error ios 8.4 simulator en xcode 7

Question:

I am trying to download the iOS 8.4 simulator in Xcode 7 and it returns this error:

Could not download and install ios 8.4. Authorization is required to install the packages.

Before that I entered my user password.

Answer:

To do this, run Xcode as root with the sudo command and install within that session:

sudo /Applications/Xcode.app/Contents/MacOS/Xcode

Once you have installed you must exit and start normally.

You should be careful if you have projects open when you use sudo to launch Xcode.

Scroll to Top